Blog Fiasco

November 9, 2009

Accessing Taleo from Mac or Linux

Filed under: Linux,mac,The Internet — Tags: , , , , , — bcotton @ 12:47 pm

Some companies (including my own employer) use a company called Taleo to manage the hiring and recruitment process.  As an applicant, I’ve not been very impressed with it, but that’s neither here nor there.  From the applicant side, you can use just about any browser to fill out the forms and submit your application.  However, if you’re a hiring manager, Taleo expects that you’ll be using the Internet Explorer browser.  If you’re on a Windows machine, that’s probably available to you.  For Mac and Linux users, it’s not an option.

So what can you do?  You can either go find a Windows machine to use, or you can try to run Internet Explorer using Wine.  Neither of those are necessarily that appealing.  Fortunately, there’s a third option, which is to use the (closed-source but free-as-in-beer) Opera browser.  Once you’ve got that installed, it’s a quick process to get Taleo workin* In Preferences, click on the “Advanced” tab and select “Content”

  • Click the “Manage Site Preferences…” button
  • Click the “Add…” button
  • Enter your Taleo site (e.g. “company.taleo.net” or “taleo.com”) in the “Site” field
  • Choose “Open all pop-ups” in the “Pop-ups” drop-down menu
  • Click the “Network tab”
  • Select “Mask as Internet Explorer” in the “Browser identification” drop-down menu (note that “Identify as Internet Explorer” will NOT work)
  • Click “OK”
  • Click “Close”
  • Click “OK”

That’s all it takes.  As a bonus, you now have the very capable, stable, and secure Opera browser installed.

5 Comments »

  1. This makes my life so much easier. Thanks!

    Comment by orangeshirtguy — November 9, 2009 @ 1:08 pm

  2. Good tip,
    but there are some misfunctions : in the staffing webtop,
    I can’t click on the “candidates” or “requisitions” tabs :(

    (and in the admin webtop I can’t open any file tree…)

    Perhaps there’s another setting I missed ?

    Thanks for help if you can :)

    Comment by Patrice — November 18, 2009 @ 5:41 am

  3. Patrice,

    I’m sorry it didn’t work for you. Unfortunately, my only access is via the Manager WebTop, so I can’t try to reproduce your problem. All I can suggest is that you go back and double-check all of the settings (and try using both “taleo.net” and “taleo.com” in the site field to make sure you catch all possibilities. You might also try “*.taleo.net” and “*.taleo.com” and see if that makes any difference).

    Good luck!

    Comment by bcotton — November 18, 2009 @ 10:48 am

  4. Hi,

    I’m a job-seeker using Ubuntu 9.10.
    Opera with these settings seems to work much better for me also.
    Firefox and Chromium-browser both go away for a long time when performing most tasks on taleo.
    (This is part of some kind of pre-screening test, right? :-) )

    Thanks!

    Comment by dangerjim — April 1, 2010 @ 1:59 pm

  5. As a job seeker, Taleo software is cumbersome and frustrating to us. Unfortunately, many large firms seem to be exclusively listed on Taleo. Simple searches cannot be repeated easily, saving criteria does not result in the same search, the user can’t open a listing and then return to the remaining listings without closing out the system and restarting the entire process. Isn’t there some better program out there?

    Comment by beth alison — February 20, 2011 @ 9:47 pm

RSS feed for comments on this post. TrackBack URL

Leave a comment

Powered by WordPress